Appeared in the Proceedings of International Conference on Systematics, Cybernetics & Informatics 2008
(ICSCI 2008), held at Hyderabad, India

MR Brain Volume Analysis Using BrainAssist™
Jeny Rajan1, K. Kannan1, Thomas Francis1, C. Kesavadas2, Chandrasekhar P.S1
1

Medical Imaging Research Group, Healthcare Division, NeST, Technopark, Trivandrum, India
2
Dept. of Radiology, SCTIMST, Trivandrum, India
{jenyrajan@gmail.com, kannan_nk@yahoo.co.in, thomas.of@nestgroup.net,
kesav@sctimst.ac.in, chandrasekhar.ps@nestgroup.net}

Abstract
In this paper we present a recently developed tool
named BrainAssist, which can be used for the study and
analysis of brain abnormalities like Focal Cortical Dysplasia
(FCD), Heterotopia and Multiple Sclerosis (MS). For the
analysis of FCD and Heterotopia we used T1 weighted MR
images and for the analysis of Multiple Sclerosis we used
Proton Density (PD) images. 52 patients were studied. Out of
52 cases 36 were affected with FCDs, 6 with MS lesions and
10 normal cases. Preoperative MR images were acquired on a
1.5-T scanner (Siemens Medical Systems, Germany). The
acquired 3D MRI data set consist of approximately 120 T1
weighted coronal slices with flip angle 15°, matrix size 256 x
224, FOV 256, thickness 1.5 mm and pixel spacing 0.89 mm.
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1. Introduction
BrainAssist is a recently developed comprehensive, user
friendly, state-of-the-art medical image analysis tool used for
the detection and analysis of Focal Cortical Dysplasia,
Heterotopia and Multiple Sclerosis from T1 and PD weighted
MR brain images. FCD lesions [1-3] are difficult to
distinguish from non-lesional cortex and their delineation on
MRI is a challenging task. Though sequences like FLAIR
(fluid attenuated inversion recovery) can detect a large
majority of these lesions, there are smaller lesions without
signal changes that can easily go unnoticed by the naked eye.
Although MRI has allowed the recognition of FCD in an
increased number of patients, standard radiological evaluation
fails to identify lesions in a large number of cases due to their
subtlety and the complexity of the cortex convolution.
BrainAssist assists the radiologists and neurologists
in identifying the lesions based on the characteristics of FCDs
like increased cortical thickness, reduced demarcation of the
gray-white matter junction and hyperdensity of gray and
subcortical white matter [1-3]. The tool highlights the
suspected FCD areas. Heterotopia is also characterized as a
type of cortical dysplasia.
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Heterotopia [4, 5] is a neurological disorder caused
by clumps of grey matter being located in the wrong part of
the brain. Sub-cortical focal heterotopia appears as islands of
gray matter within the white matter. BrainAssist highlights the
dislocated gray matter in the white matter. Multiple Sclerosis
[6–9] is analyzed based its high intensity in the Proton Density
(PD) MR image. For the analysis of FCDs and Heterotopia,
T1 weighted MR images and for the analysis of Multiple
Sclerosis, Proton Density (PD) images are used. The most
carefully collected data from international surveys indicate
that about 1 adult in 200 suffers from recurrent epilepsy. If we
include infants who have suffered seizures caused by fever
(usually a temporary problem) and adults who have only ever
had one seizure, the figure rises to about 1 person in 80 [10].
Almost 25% of brain epilepsy is caused due to FCD. The
survey indicates the importance of having automatic and
perfect tools for FCD analysis.
This paper is organized as follows: Section 2
describes the pre-processing operations, such as, scalp
removal & tissue segmentation. Analysis of FCD, Heterotopia
and Multiple Sclerosis are explained in Sections 3,4 and 5
respectively. Section 6 deals with image saving options.
Finally conclusion and remarks are added in section 7.

2. Pre-Processing Operations
To find the Focal Cortical Dysplasia lesion areas
with BrainAssist, we have to give T1 weighted MR volume (in
DICOM format) as the input. The Graphical User Interface of
BrainAssist is shown in Fig1. The upper panel shows input of
the three different orthogonal views of volume data such as
coronal, sagittal and transverse / axial view respectively. The
lower panel shows output image of each and every process. If
we click on the image in any one of the views, the other views
will automatically synchronized with the corresponding
position. The upper right most panel shows the histogram of
the 3D volume image. The text boxes shown below the
histogram is reserved for entering threshold values. These
threshold values are used for gaussian curve fitting and brain
tissue segmentation. The patient info panel displays the patient
information like patient name, age, sex, ID, date of birth and
image modality. The lower right most panel is devoted for
showing volumetric information of brain.
2.1 Loading an Image
BrainAssist supports 2D and 3D DICOM files with
extension of .dcm. To load the volume image we can use
either File menu (File -> Open) or we can use Toolbar.
BrainAssist displays the input` data in three orthogonal views
(Coronal, Sagittal & Transverse). While loading the volume
data / image the patient’s information are gathered from the
header file and is displayed in the patient information area as

shown in Fig.1 and the voxels are converted into 1 x 1 x 1
scaling space. Fig.2 (a) shows the Browse for open a file. Fig.
2 (b) shows the scaled version of T1 weighted MRI.
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dataset. In existing tools, the cerebrum extraction is achieved
by registering the image with brain atlas. But in BrainAssist, it
is implemented based on statistical information of brain. Fig. 4
shows the cerebellum removed brain volume.
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Figure 1: Graphical user Interface of BrainAssist

Figure: 4 (a) Original brain volume in different isometric
view, (b) Scalp removed, (c) Cerebrum segmented from scalp
removed brain volume
3.
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Figure: 2 (a) File open window, (b) Three different
orthogonal view
2.2 Scalp Removal
BrainAssist supports fully automated scalp-stripping
operation. The scalp removing operation consists of multistage procedure. For removing the scalp it’s enough to press
the scalp removal button in the Tool bar icon or Tool menu
(Tool->Scalp Removal). Before FCD analysis we should
remove the non-brain tissues, such as scalp (skin that covers
the top of the head) and lipid areas from the MR T1 weighted
images. The scalp removing operation is the combination of
morphological operations and 3D connected component
analysis. Fig.3 shows the scalp removed MRI volume image.

FCD Analysis

On T1-weighted Magnetic Resonance Imaging
(MRI), FCD is generally characterized by variable degrees of
cortical thickening, reduced demarcation of the gray-white
matter junction and hyper-density of gray and sub-cortical
white matter. FCDs are always classified as GrayMatter. So
it’s enough to keep GrayMatter area for FCD analysis.
3.1 GrayMatter Segmentation
The segmentation is done with fitting gaussian curve
on the histogram of scalp removed volume. In the histogram
we can see three peaks, the first peak corresponds to CSF, the
middle peak corresponds to gray matter and the last peak
correspond to white matter as shown in Fig.5.
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Figure 3: Scalp Removed Brain Volume
2.3 Cerebrum Segmentation
Removing cerebellum from scalp stripped brain
image can reduce false negatives in automatic FCD analysis
procedure. BrainAssist can remove cerebellum area from the
scalp removed brain volume without any reference atlas

Figure: 5 Histogram of scalp removed image
For isolating gray matter click on the gray matter
peak, and then click the text box named GM peak. Now, we
can see the corresponding value appeared in the text box.
After selecting of gray matter peak, click on the white mater

peak and repeat the earlier steps, the white matter peak value
appear in the WM peak text box. After selecting booth peaks,
click the Draw button to fit the Gaussian curve on the
histogram. Fig.6 shows the two curves fitted on the histogram.
Red curve corresponds to gray matter and green curve
corresponds to the white matter. We can isolate the gray
matter area by clicking the intersection of gray-white matter
and other end of gray matter (starting end) in the curve. Now
click the submit button, we can see the areas other than gray
matter is subtracted from the brain image. Fig.7 shows the
GrayMatter segmented image
Gray Matter

should be checked and by moving the slider bar we can
change opacity of the original image. Fig.9 shows the super
imposed image.
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Figure: 9 Complex map Superimposed with Original Image
4.

Figure: 6 Gaussian Curves fitted on the histogram

Heterotopia Analysis

Heterotopia appears as islands of gray matter within
the white matter [4, 5], BrainAssist highlights the dislocated
gray matter in the white matter. Heterotopia is characterized as
a type of cortical dysplasia hence the procedure for analysis
the heterotopia is same as the FCD analysis. First we have to
remove the scalp by clicking scalp removal button. The nature
of Heterotopia is dislocation of gray matter in the white mater.
So, we have to separate gray matter alone by using scalpremoved histogram (explained in section 3.1). After gray
matter segmentation, click on FCD analysis icon in the Tool
bar or Tool menu (Tools -> FCD analysis). Fig.10 shows an
example of Heterotopia diagnosis. The areas near to white
color are suspected areas.

Figure: 7 Gray Matter Segmentation
After gray matter segmentation simply click on FCD
analysis icon in the Tool bar or Tool menu (Tool -> FCD
analysis) we can start the FCD analysis process. While
running this process, it will automatically calculate the 3D
thickness map and compute complex map. For easy
visualization and analysis, the complex map is displayed using
hot colormap. Fig.8 shows the complex map with hot
colormap. The areas near to white color are suspected areas.
Figure: 10 Heterotopia Analyses
5.

Figure: 8 Complex Map with Hot Color map
BrainAssist provides copious options for better
analysis like, blending the complex map with original image.
For activating the blending option, the blending check box

Multiple Sclerosis Analysis

Multiple Sclerosis (MS) Lesion is an inflammatory
disease of the Central Nervous System (CNS). The pathology
underlying this disorder is the formation of multiple
demyelinated plaques. Lesions are typically widely
disseminated in the central nervous system (CNS), with the
predilection of well myelinated areas: the optic nerve,
periventricular white matter, corpus callosum, cerebellum and
cervical cord. In people affected by MS Lesion, patches of
damage called plaques or lesions appear in seemingly random
areas of the CNS white matter. MS lesion is characterized as a
type of white matter lesion and it spreads more than one area.
[6 - 9] So, MS lesion analysis is not very similar as FCD

analysis. First, we have to remove the scalp by clicking scalp
removal button. For MS Lesion analysis its enough to search
in high intensity area alone in MR Proton Density (PD)
images. So, the high intensity area has to be first segmented
from MR PD images. After high intensity segmentation by
simply click on MS Lesions analysis icon in the Tool bar or
Tool menu (Tool -> MS Lesions analysis) we can start the MS
Lesion analysis process. Fig. 11. shows the complex map with
hot colormap. The areas near to white color are suspected
areas.

Figure: 11 Multiple Sclerosis Analysis
6.

Image Saving Option

Brain Assist provides two different type of Image
saving options, (i) single slice image saving option and (ii)
Volume Image saving option. In single image saving option
has two image formats (i) BMP image format and (ii)
DICOM image format.
An image can be saved as DCM image format by
selecting the Save As option under the File menu or to quick
save an image, click Save as DICOM image on the Standard
Toolbar.
An image can be saved as BMP image format by
selecting the Save As option under the File menu or to quick
save an image, click
Save as Bmp image on the Standard
Toolbar.
Volume image can be saved as DCM image format
by selecting the Save As Volume... option under the File menu
or to quick save volume image, click Save as image volume
on the Standard Toolbar.
7.

Conclusion

In conclusion, BrainAssist is a comprehensive, user
friendly, state-of-the-art medical image analysis tool. Scalp
removal and Tissue classification is successfully achieved
without any brain atlas. The tool assists Radiologists and other
clinicians to effectively analyse MR Brain images.
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